Joomla 1.0 verouderd?

 

joomlaEen korte zoektocht via Google.nl geeft aan dat er nog steeds veel Joomla 1.0 sites in gebruik zijn. Van sportvereniging tot hondenuitlaatservice. Maar ook van internationaal opererende bedrijven en website-portals! En dat verbaast me.

Waarom? Omdat Joomla 1.0.15 (de laatste 1.0 versie) dateert van september 2008. De support (het uitbrengen van veiligheids updates) is gestopt per 22 juli 2009. Tevens zijn verschillende extensies (componenten en modules) waarmee je Joomla extra functionaliteit geeft, ook verouderd. Kortom, een potentieel risico, omdat verouderde software bugs bevatten en dus gemakkelijk gehackt kunnen worden. En zo af en toe gebeurd dat ook, helaas.

Joomla 1.0 sites draaien vaak op servers met een oudere PHP versie. De nieuwe PHP versie 5.3, die alweer meer dan 1 jaar beschikbaar is, is weer niet geschikt voor Joomla 1.0. Op het moment dat jouw hostingprovider nu alsnog, vanwege problemen op de server, over gaat naar PHP-versie 5.3, zal je Joomla site opeens niet meer werken. Helaas komt dat nog wel eens voor. Je kunt ook vraagtekens zetten bij een hostingprovider die nog een oude (lees: onveilige) PHP versie gebruikt. Van de andere kant, ook ik heb klanten die nog niet over willen naar een nieuwere Joomla website, waardoor ik ook wel weer blij ben dat deze sites gehost kunnen worden op een oudere PHP versie. Het is uiteindelijk de verantwoording van de klant zelf.
http://www.byte.nl/wiki/Joomla_Php_Upgrade

Wat te doen? Heb je nog steeds een Joomla 1.0 site, check dan in de backend (via domeinnaam.nl/administrator) welke versie je hebt. Joomla 1.0.15 is de laatste versie die op zich nu nog goed werkt. Check ook of de extra componenten en modules die zijn geïnstalleerd zijn geupdate naar de laatste versie. Dit betekent nog niet dat je website veilig is. Het is raadzaam om op korte termijn over te gaan naar een nieuwere versie van Joomla.
Je hebt dan keuze uit Joomla 1.5 of Joomla 1.6/1.7. Joomla 1.5 bestaat alweer enkele jaren en biedt de meeste mogelijkheden voor het installeren van extra functionaliteit (componenten en modules). Beter is om naar Joomla 1.6 (jan 2011) of Joomla 1.7 (juli 2011) over te gaan. Helaas zijn voor deze versies nog lang niet alle extra extensies beschikbaar. Overleg daarom ook met je webdesigner (of 1-2-appletree) welke functionaliteit nodig is en of deze beschikbaar is in Joomla 1.6/1.7 of toch nog in Joomla 1.5

Tags: Joomla

Contact

1-2-appletree
tel: 078-6179510
info@1-2-appletree.nl

Offerte aanvragen

KvK: 24316247

Internetburo Dordrecht

Als internet bureau helpen wij ZZP-ers, bedrijven en organisaties uit heel Nederland met het ontwikkelen van websites. Vanuit onze vestiging in Dordrecht werken wij voor regionale (Dordrecht, Rotterdam) en nationale opdrachtgevers.